Jump to content
ilanr1

Throttle bodies are out , how can i insert them back ?

Recommended Posts

Hi , i managed to take the throttle bodies out by shaking them front and rear directions.

After a good clean i want to put them back again , it is not easy..

Is there a method or a trick how can I do that ?.

Thanks

Share this post


Link to post
Share on other sites

With heat and age the rubber gets hard. Heat the rubber with a heat gun or blow dryer and lube with silicone spray.

Why did you pull your TB's?

  • Thumbsup 2

Share this post


Link to post
Share on other sites

Hi , I'm trying to switch to tracer 900 gt.

I bought one after an accident , all the electronics are good and the engine.

The throttle bodies are different so i need to replace them.

I replaced the entire loom.

Right now i have replaced all the electronics but the engine is not starting.

The fuel pump is priming , the starter is good and strong.

The blinking of the imobilizer is turned off after that i turn on the key.

It looks like an electronic problem.

Any thoughts ?.

Thanks

 

 

  • Thumbsup 1

Share this post


Link to post
Share on other sites

Wow, you're ambitious!!


2015 red FJ-09 / touring bags / oil plug mod

Share this post


Link to post
Share on other sites

Yes very ambitious , right now there is no spark at all of the plugs... , The immobilizer light goes off after turning the main switch to on.

Is there a fuse that control the ignition ?.

Or it looks like the ecu ?.

The Gt that i bought was running , so i don't know what i connected wrong...

I'll check all the fuses and the connectors tomorrow , any suggestions are welcome.

Besides that the motor is not running , all is working on the colour display..

Thanks

 

Share this post


Link to post
Share on other sites
40 minutes ago, knyte said:

Wow, you're ambitious!!

Which borders on crazy.  The sky is the limit on doing what you're doing, just going to have to go through and re-check ALL of your work.  We don't have the immobilizer here, sounds suspect to me, probably kills ignition as anti-theft.

Did you also bring over the ignition lock and using the correct key?  Key has a chip or transponder right?

  • Thumbsup 2

Share this post


Link to post
Share on other sites

Yes , i have replaced the main switch with the one from the Gt , this works with the ECU of the Gt.

Right now i don't have a running engine.

I just took the electronics from the Gt and right now I'm stuck.

My bikd was working fine before this surgery...

Share this post


Link to post
Share on other sites

Are you working on this with a access to a service manual? Electrical schematic for the GT would come handy... or like @peteinpa mentioned... trace the steps and double-check connections. Unfortunately you lost access to fault codes with the fancy dash. Good luck.

Edited by piotrek
  • Thumbsup 1

canada.gif.22c5f8bdb95643b878d06c336f5fe29f.gif - IBA #66956 - 2015 Yamaha FJ-09

Share this post


Link to post
Share on other sites

This is from a 2015 service manual but 'may' help with some fault finding?

Good luck.

image.thumb.png.86ac6f14873b331d10d29dae2551d516.png

image.png.c03fd9fa0b8cfccaed0bfb47bf4d35e2.png

  • Thumbsup 1

Share this post


Link to post
Share on other sites

Yes , i have the electronic version of the service manual gt version

  • Thumbsup 1

Share this post


Link to post
Share on other sites

Problem solved !!! - the pickup sensor cable was not connected !!!.

Tracer gt now !!!

  • Thumbsup 2
  • Like 2

Share this post


Link to post
Share on other sites

Color me impressed! You have to be the first to do this.

  • Thumbsup 2

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×