Jump to content

Dark&Stormy

Member
  • Content Count

    203
  • Joined

  • Last visited

  • Days Won

    2

Dark&Stormy last won the day on August 5

Dark&Stormy had the most liked content!

Community Reputation

414 Excellent

About Dark&Stormy

  • Birthday 01/16/1988

Converted

  • location
    Saskatchewan

Recent Profile Visitors

258 profile views
  1. So I just straightened the studs out and installed the LV one more time and problem solved. 🤦‍♂️
  2. Do you happen to know the size? Can you get them at any autoparts store or is this gonna be a dealer order?
  3. Just tried putting the stock exhaust back on only to discover the shitty aluminum LV flanges that bent like a taco had actually bent my exhaust studs inward. Now the stock stainless steel flange wont fit. Thanks LeoVince. Theres good chance that the bent exhaust studs are preventing the collars from seating properly. What a can of worms.
  4. Just tried putting the stock exhaust back on only to discover the shitty aluminum LV flanges that bent like a taco had actually bent my exhaust studs inward. Now the stock stainless steel flange wont fit. Thanks LeoVince.
  5. Its new. Also the midpipe is damn near rubbing on the bottom right corner of the oil pan. I emailed both the seller and LVUSA. The thing is the miss matched header pipes shouldnt matter that much since you place the collars into the ports and secure them with the flanges and the 12mm nuts (they should be flush) Then you wiggle the pipes in and they're held inplace with the springs. Ill try new exhaust gaskets to see if that makes a difference. Also the flanges cant be torqued to 14ft/lbs as LV says or else they will bend like cheese. I bent one trying to torque it down and had to flatten it out in a 20 ton press. The installation instructions are complete garbage and LV has a crappy minute long video showing the final 3 steps of installation..
  6. I keep trying to refit the headers to the ports but each time I get them flush and tightened down I start the engine all I can hear is a loud exhaust leak coming from ports. Is this normal as in it will go away after a few heat cycles? Ive tried refitting it 3 times I even tried without the copper gaskets installed. The instructions are so vague and lost in translation they are laughable. This is supposed to be a reputable brand yeah?
  7. So after the fourth assembly (Thats right!) I finallly got it set right. Thanks Skip for the tip on placing the shims into valve keepers.
  8. I pulled the cams and the two exhaust tappets on cylinder #1, I dont think the shims stayed seated on reassembly. I Re-set the shims with lubriplate to help them stay inplace again and carefully installed the tappets. Ive been using a telescopic magnet to keep the shim inline and to help slide the tappet into place. I reinstalled the cams and cct, turned the crank to TDC#1, checked the clearance again. This time the left exhaust tappet is on target but the right is still too tight for any feeler gauge. Maybe what is happening is when I pull the magnet off of the tappet the shim slides out of place? I was careful to pull it off straight but damn this job is eating up all of my free time. The cct removal/install is by far most time consuming part of this job.
  9. The reason the bolts are rusting is due to galvanic corrosion, carbon steel and aluminum dont mate well. You could replace them with stainless steel (good luck finding bolts that size in stainless) or clean them up like you did and apply a liberal coating of antisieze.
  10. Or you could take your header to a welding shop and get it repaired in less time than you've spent on this forum whining about it.
  11. YOSHIMURA FJ09 Y-SERIES FULL EXHAUST SYSTEMS QUICK SHIP! 2SC-E46D0-V0-00 YOSHIMURA FJ09 Y-SERIES FULL... If anyone is looking to buy one of these I found one located in Reno on Ebay and the seller is accepting offers. I put in a lowball offer of $600 and the seller said he would do $799 plus free US shipping. Its was installed on a display so its basiclly new. I think its a nice looking system but no shipping option to Canada so im gonna pass on this.
  12. Quick question... kind of a head scratcher on my end. I changed the exhaust shims and after I rechecked the clearance I found I now have 0mm clearance on cyclinder 1 exhaust valves and left intake valve but cylinder 2 and 3 are right on target. Im guessing the problem is the shims did not stay seated when I installed the tappets? Any ideas??🤔
×